当掲示板は、AuroCADマクロ屋本舗 の掲示板です。
AutoCADのマクロ に関する質問の前に 【 マクロ使用前の注意事項 】 を、必ずお読みください。

尚、新規投稿フォーム下の【 新規投降時のお願い 】を確認の上、新規投降をお願い致します。            
管理人:とってぃ
64bit acadremocon
お世話になっています。

64bitのマシンでacadremoconを使うにはどうしたらいいでしょうか?

聞く場所が違ってたら申し訳ありませんが、今非常に困ってまして・・・。
  • SORA
  • 2016/07/12 (Tue) 19:58:48
Re: 64bit acadremocon
64bitでも使えた気がしますがその前に
AutoCADのバージョンは何でしょうか?
2016以降は対応していない仕様となってるみたいですよ。
  • とってぃ
  • 2016/07/13 (Wed) 08:06:13
Re: 64bit acadremocon
失礼いたしました、バージョンは2017です。
64bitだから使えないというわけではないのですね・・・勉強不足でした。

今後acadremoconに変わるものもなさそうですよね。非常にこまりました。
  • SORA
  • 2016/07/13 (Wed) 09:01:22
Re: 64bit acadremocon
度々すみません。間違えました。

64bitでバージョンは2014を使っています。
  • SORA
  • 2016/07/13 (Wed) 09:18:24
Re: 64bit acadremocon
acadremoconのバージョンは何ですか?
  • とってぃ
  • 2016/07/13 (Wed) 10:36:41
Re: 64bit acadremocon
VBSファイルを直接書き換えて下さい。

詳細は下記で・・・
http://www7b.biglobe.ne.jp/~den-eng/Free/cgi-bin/c-board/c-board.cgi

飛ばない場合は
http://www7b.biglobe.ne.jp/~den-eng/index.html から
「なんでも掲示板(Jww、AutoCAD、道路、設計)」へ飛んで下さい。
  • Den
  • 2016/07/13 (Wed) 12:09:07
Re: 64bit acadremocon
とってぃさん、Denさんありがとうございますm(_ _)m

一度この掲示板を熟読して試してみます!
  • SORA
  • 2016/07/13 (Wed) 13:14:56
Re: 64bit acadremocon
失礼致します。

「acadremocon.netホーム 掲示板」にて、「MustRun.zip」を公開
していた極楽鳥という者です。


以前「acadremocon.netホーム 掲示板」にて公開していました版に、
若干の改訂を施した版を以下のサイトで公開しています。

今後はそちらを参照願います。


https://bitbucket.org/birds_of_paradise_2015/mustrun
  • 極楽鳥
  • 2016/07/21 (Thu) 13:36:21
Re: 64bit acadremocon
極楽鳥さん

わざわざご連絡ありがとうございます。 m(_ _)m
  • とってぃ
  • 2016/07/21 (Thu) 14:52:55
Re: 64bit acadremocon
極楽鳥さん

AcadRemocon掲示板ではお世話になりました。

無許可で自分の掲示板に公開してすみません。
  • Den
  • 2016/07/23 (Sat) 10:46:06
Re: 64bit acadremocon
Win7 64bit aoutcad2017 で MustRun を実装してみましたがうまく走りません
バージョンが AcadRemocon.dll 3.3.0.2 なのですが
AcadRemocon.dll 3.4.0.3 じゃないと行けないのでしょうか?
何か情報ありましたら教えてください 
  • nakashima
  • 2016/12/28 (Wed) 11:26:54
Re: 64bit acadremocon
AcadRemocon は AutoCAD 2014 までしか正常に動きません。(3.4.0.3使用時)
2015以降では、コマンドラインの情報を取得できなくなってしまいました。
ちなみに、3.3.0.2だと正常に動くのは2009くらいまでじゃなかったかな?と記憶してます。
  • Lon
  • 2016/12/31 (Sat) 00:38:16
Re: 64bit acadremocon
情報ありがとうございました。
そうですかーとても残念です。
特にMarume_3.vbsが便利で2012では多用していたのですが・・・
どうしようもないですね。
  • nakashima
  • 2017/01/06 (Fri) 23:13:38
Re: 64bit acadremocon
いきなり書き込みすいません。
8年ぶりにAutoCADを使う仕事に復帰し、acadremoconが使えなくなっていることを知り、残念です。

Acadremoconで使っていたvbsプログラムを、Autocad2016でどうにかして動かす方法はないのでしょうか?

  • Cherry River
  • 2017/01/26 (Thu) 23:29:22
Re: 64bit acadremocon
現状、acadremoconのサポートが終了していますので
確かバージョン2015以降は、動作しない状況となっています。

自分は2013を使用していますが
バージョンアップにためらっています・・・(汗
  • とってぃ
  • 2017/01/27 (Fri) 08:05:14
Re: 64bit acadremocon
64bitでは無いのですが acadrimocomの話が出ているので相談させて下さい
当方最近まで 2005を使用していたのですが 昨年末より 仕事の都合上2013ltを使用する事になりまして
メインで使用しているコマンドは 10年ぐらい前にとっていさんに製作して頂いた 四算演算構築線及び
こちらのマクロ集に紹介されているマクロと VBSなのですが マクロの移行は問題無く
(バージョンアップ版を掲載して頂いているので)出来たのですが 
vbsに関しては当方acadrimocon3.2.0しか持っていない為
本体がwin7の32bitでしたので 何とかインストールし 現在も使用はしているのですが トラブルが多く
又元々使用出来ないvbsも多い状態で困っていた為 KJUさんに有料ソフトの購入依頼メールを送ったのですが
何の返事も無い状態です もう諦めるしかないかとも思っているのですが 駄目元でのお願いですが
もし出来る事ならacdrimocon3.4.2を譲って頂く事は出来ないでしょうか
尚このメッセージの内容に 問題が在る場合は 削除も合わせてお願いします(_ _)






  • hama
  • MAIL
  • 2017/02/22 (Wed) 20:59:53
Re: 64bit acadremocon
当方もLT2013+acadremocon Ver3.2です。
Ver3.4は持っていないです。すみません。

ただ、Ver3.4を入れたとしても
過去のVBSファイルもマクロと同様に
全てのバージョンに対応しているわけではないので
どちらにしても、作り直したりする必要があるかと思います。
  • とってぃ
  • 2017/02/23 (Thu) 08:23:55
Re: 64bit acadremocon
私が持っているのは、AcadRemocon 3.4.0.3 で、それ以上新しい物は持っていません。

AcadRemoconを2013で使うには、CAD側の設定も色々と変える必要があります。
CAD側の設定次第で、3.2.0のままで動くVBSも多くあるでしょう。

そして、動かないVBSの中でも、とってぃさんが言われてる様に、
AcadRemoconをバージョンアップすれば動くVBSも有れば、
コード(プログラム内容)を書き換える必要がある物もあります。

また、稀なケースですが、3.2.0ではそのまま動くけど、3.4.0.3にすると、
コードを書き換えなければならない。という事もあります。
(それが面倒で、ずっと3.2.0のままの人も居ました。)

2013のCAD設定、
「ダイナミック入力OFFで、コマンドラインはドッキング」これは必須。
「オブジェクトプロパティ管理は非表示で、コマンドラインはUSEOLDCOMMANDLINE=TRUE」これは強く推奨
他にも、幾つか有ったと思いますが、私自身が2013を使用した経験が有りませんので、忘れました。

また、
OSがWindows8以降だと、セキュリティ関係の設定も必要になるケースが出てきます。
AcadRemoconを管理者権限で動く様に設定し、AcadRemocon.iniのアクセス制限をフルアクセスに変更とか。
ユーザーアカウント制御をoffにするとか。

これは、各パソコンの仕様により変わってくる様で、何もしなくてもいいPCもあれば、
何をしてもアクセス制限が外れないPCもあります。

ちなみに、Windows7ではユーザーアカウント制御の設定を最低(スライダーを1番下)にすれば、
≒off状態 なのですが、
Windows8以降は最低≠offです。(あくまでも最低限の制御はされている)
offにするには、レジストリを直接変更する必要があります。
詳しくはググって下さい。



↓3.4.0.3ダウンロード(現在より12時間後まで可能)
http://firestorage.jp/download/9f84867d339aa7854ff2dc37b1f32bb2e333d6ff
  • Lon
  • 2017/02/23 (Thu) 09:21:00
Re: 64bit acadremocon
とってぃさん Lonさん お忙しい中 ありがとうございます(_ _)
とっていさんも 3.2.0とは思っておらず 失礼しました 
そしてLonさん ありがとうございます 頂きました 3.4.03ありがたく使わせていただきます
又くわしい説明まで書いていただき 合わせて感謝です これだけ判れば 後は何とか出来ると思います
本当にありがとうございました(_ _)

  • hama
  • MAIL
  • 2017/02/23 (Thu) 20:55:14
Re: 64bit acadremocon
Lon様、acadremocon 3.4.0.3を再度アップを御願いします。
  • kazu
  • 2017/03/10 (Fri) 16:20:58

返信フォーム






プレビュー (投稿前に内容を確認)